amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > Qemu AmigaOs4.1/Morphos [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

03.09.2022, 23:13 Uhr

Maijestro
Posts: 20
Nutzer
Kurze info:

Es wird wahrscheinlich die wenigsten interessieren, aber ich habe das ganze getestet mit Qemu 7.1.0 unter MacOs Monterey. Ich habe mich intensiv damit beschäftigen müssen um es überhaupt in stande zu bekommen.

Ich möchte nur damit sagen das der Weg sehr lang war......ich musste dafür unter MacOs sämtliche developer tools installieren.Da es kein MacOs Build von Qemu gibt (alles veraltet) den man einfach downloaden kann wie es unter Windows üblich ist.

Die Sam460 Version von AmigaOs 4.1 habe ich leider zum derzeitigen Zeitpunkt nicht zum laufen bekommen bzw. es war mir nicht möglich diese zu installieren, da zu viele Arteffakte bei der Workbench entstanden sind.

Mit der Pegasos 2 Version von AmigaOs 4.1 die ich mir gerade bestellt habe werde ich es noch versuchen, über die Qemu Emulation mit Pegasos 2 Board Emulation.

OK.... dachte ich wenn Amiga Os 4.1 nicht geht probierst du als Alternative halt MorphOs in der aktuellen Version aus...

und was soll ich euch sagen ich bin positiv überrascht wie schnell die Emulation ist gegenüber WinUae...mit AmigaOs 4.1 auf mein Mac Studio.

Meine config für QEMU unter MacOs:

Installation Morphos

qemu-system-ppc -machine mac99,via=pmu -m 1024 -vga none -device sm501 -cdrom morphos-3.17.iso -boot d -prom-env "boot-device=cd:,\mac_ppc32\boot.img" -bios openbios-qemu.elf -hda mos.img -drive file=mos.img,if=none,id=hd-drive,format=raw -serial stdio

Nach der Installation ohne CD booten (ohne internet)

qemu-system-ppc -machine mac99,via=pmu -m 1024 -vga none -device sm501 -boot d -prom-env "boot-device=hd:,\boot.img" -bios openbios-qemu.elf -device ide-hd,drive=hd-drive,bus=ide.0 -drive file=mos.img,if=none,id=hd-drive,format=raw -serial stdio -net nic,model=rtl8139 -net user

(Mit internet)

qemu-system-ppc -machine mac99,via=pmu -m 1024 -vga none -device sm501 -boot d -prom-env "boot-device=hd:,\boot.img" -bios openbios-qemu.elf -device ide-hd,drive=hd-drive,bus=ide.0 -drive file=mos.img,if=none,id=hd-drive,format=raw -serial stdio

Mit Internet und mehr Speicher

qemu-system-ppc -machine mac99,via=pmu -m 2048 -vga none -device sm501 -boot d -prom-env "boot-device=hd:,\boot.img" -bios openbios-qemu.elf -device ide-hd,drive=hd-drive,bus=ide.0 -drive file=mos.img,if=none,id=hd-drive,format=raw -serial stdio


Meine Hardware:

Apple M1 Max Chip
10‑Core CPU mit 8 Performance-Kernen und 2 Effizienz-Kernen
24‑Core GPU
16‑Core Neural Engine
400 GB/s Speicher­bandbreite

[ - Antworten - Zitieren - Direktlink - ]

04.09.2022, 06:15 Uhr

Primax
Posts: 324
Nutzer
@Maijestro:

Hallo. Danke für deinen Erfahrungsbericht. Finde ich immer spannend! :)
Eine Sache verstehe ich nicht: du hattest doch AmigaOS 4.1 schon unter FS-UAE laufen. Was war das denn für eine OS4-Version? Nicht die Classic? Gibt es da noch eine andere, spezielle Pegasos-Version?

Der direkte Vergleich FS-UAE mit QEMU wäre natürlich spannend...was die Geschwindigkeit betrifft, aber auch Stabilität etc.

Hast du unter MorphOS mal die aktuelle Wayfarer-Browserversion getestet?

Grüße, Daniel

[ - Antworten - Zitieren - Direktlink - ]

04.09.2022, 09:45 Uhr

Maijestro
Posts: 20
Nutzer
@Primax:


Hi Daniel,

ja es ist richtig AmigaOs 4.1 FE Classic habe ich bereits unter WinUae, sowie auch unter FS-UAE getestet .Von den Emulatoren liegen keine nativen Versionen für MacOS vor und so konnte ich nur über Umwegen alles installieren.

WinUae läuft nur emuliert mit Hilfe von Wine unter MacOS. Das Programm (Wine) macht es möglich unter MacOs Windows Software nutzen zu können.

FS-UAE gibt es ebenfalls nur als Intel Version und wird durch Rosetta auf neueren Macs übersetzt. Das alles genügte mir nicht, da einfach zu viel Geschwindigkeit dabei verloren geht.

Als letzten Versuch entschied ich mich dann für Qemu was nativ unter MacOs mit m1 arm Prozessor läuft.

Qemu bringt die volle Sam440 und auch Pegasos 2 emulation mit sich. WinUae und auch FS-UAE tun das nicht.
Dementsprechend braucht man dafür auch die speziellen Versionen von AmigaOs 4.1 FE.
Beide kann man käuflich erwerben.

Jetzt aber zu der eigentlichen Emulation die bereits läuft:

Viel hab ich noch nicht getestet nur etwas im System gestöbert und mir alles angeguckt, Morphos ist mir relativ fremd. Fensteraufbau ist sehr schnell und das starten von Programmen läuft ohne Verzögerung. Wayfarer habe ich auch getestet nach Initialisierung der Fonts was ein klein Moment dauert startet der Browser ohne Verzögerung.

Bis jetzt gab es keine Abstürze und das System läuft sehr stabil.
Geschwindigkeit zu beschreiben ist immer etwas schwierig. Für mich persönlich ist Qemu der klare Sieger. Es läuft wirklich sehr schnell!

Was im Moment noch nicht geht es der Sound....eventuell hab ich etwas in den einstellungen vergessen unter Qemu. Da es kein Gui bzw. eine richtige Benutzeroberfläche gibt muss ich alles per Hand und über das Terminal eingeben was natürlich etwas umständlich ist.

Ich werde mal ein kurzes Video machen von der Emulation Morphos mit Qemu damit man besser versteht was ich meine.

Qemu MorphOs


Ich hab noch ein zweites Video gemacht, jetzt mit ein paar Optimierungen und Chrysalis Software Paket für MorphOs

Morphos optimiert und mit Chysalis Software Paket

Man sollte auch die Systemlast unter MacOs beachten die Emulation benötigt nicht mal 20% Cpu last....ich finde das wirklich beachtlich.

[ Dieser Beitrag wurde von Maijestro am 04.09.2022 um 20:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

04.09.2022, 11:51 Uhr

DaFreak
Posts: 253
Nutzer
8o
Danke für deinen Erfahrungsbericht! QEMU scheint auf zeitgemäßer Hardware brauchbarer zu sein als viele hier sagen.

[ Dieser Beitrag wurde von DaFreak am 04.09.2022 um 11:52 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

04.09.2022, 13:24 Uhr

Maijestro
Posts: 20
Nutzer
@DaFreak:

Ja läuft wirklich angenehm....dennoch gibt es noch viele Optimierungen zu bewältigen, Qemu ist sehr umfangreich was die Konfiguration anbelangt.

Auf der MorphOs Seite gibt es das rtl_8139pci.device zum downloaden das entspricht etwa meine config:

qemu-system-ppc -machine mac99,via=pmu -m 1024 -vga none -device sm501 -boot d -prom-env "boot-device=hd:,\boot.img" -bios openbios-qemu.elf -device ide-hd,drive=hd-drive,bus=ide.0 -drive file=mos.img,if=none,id=hd-drive,format=raw -serial stdio -net nic,model=rtl8139 -net user


Siehe letzte Zeile wo ich das Netzwerk rtl8139 eingebunden habe.

Jetzt zu meiner Frage, wohin kommen in allgemeinen .device datein unter MorphOs in meinen fall handelt es sich um das rtl_8139pci.device. Es schein ein Netzwerktreiber zu sein den ich aber unter MorphOs erst installieren muß.


Hat sich erledigt und funktioniert.

[ Dieser Beitrag wurde von Maijestro am 04.09.2022 um 19:41 Uhr geändert. ]

[ Dieser Beitrag wurde von Maijestro am 06.09.2022 um 03:37 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

04.09.2022, 20:56 Uhr

Maijestro
Posts: 20
Nutzer
Zitat:
Original von DaFreak:
8o
Danke für deinen Erfahrungsbericht! QEMU scheint auf zeitgemäßer Hardware brauchbarer zu sein als viele hier sagen.

[ Dieser Beitrag wurde von DaFreak am 04.09.2022 um 11:52 Uhr geändert. ]


Ich denke ich hab damit das Gegenteil bewiesen das es gut laufen kann. Als nächstes werde ich AmigaOs4.1 FE Pegasos 2 Edition testen...was mir persönlich wichtiger ist als die MorphOs Version. Ich will nicht sagen das MorphOs schlecht ist in vielen dingen ist es AmigaOs4.1 voraus und sehr modern gehalten.

Dennoch finde ich persönlich AmigaOs4.1 besser, es erinnert mich einfach an die zeit die ich mit mein Amiga 1200 und auch AmigaOne Xe hatte und mir kommt unter AmigaOs4.1 einfach alles viel vertrauter vor.

[ - Antworten - Zitieren - Direktlink - ]

05.09.2022, 20:55 Uhr

Primax
Posts: 324
Nutzer
@Maijestro:

Also, die Devices (ahi.device, keyboard.device, netinfo.device etc.) liegen bei mir unter "Mein MorphOS" --> "MOSSYS" --> "Devs".

[ - Antworten - Zitieren - Direktlink - ]

05.09.2022, 20:57 Uhr

Primax
Posts: 324
Nutzer
Hast du etwas dagegen, wenn ich deinen Erfahrungsbericht in den englischen News als eben solches bringe? Oder möchtest du den gar selbst schreiben? :)

Ich glaube, da interessieren sich einige für...

[ - Antworten - Zitieren - Direktlink - ]

06.09.2022, 03:36 Uhr

Maijestro
Posts: 20
Nutzer
@Primax:

Das kannst du gerne machen damit es auch anderen hilft es besser zu verstehen. Es gibt auch noch einige Ergänzungen die ich später hinzufügen werde.

Es sind kleine Optimierungen womit das Ganze noch etwas besser läuft zb. wie man das ganze mit dem ati-vga device (ATI Rage) emulation einbindet um höhere Auflösungen unter MorphOs setzen zu können. Internet Probleme löst und die Maus Geschwindigkeit verbessert.

Mein Englisch ist leider nicht so gut, darum würde ich mich freuen wenn du das übernehmen würdest.

[ - Antworten - Zitieren - Direktlink - ]

06.09.2022, 03:52 Uhr

Maijestro
Posts: 20
Nutzer
[ Dieser Beitrag wurde von Maijestro am 06.09.2022 um 03:52 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

06.09.2022, 03:54 Uhr

Maijestro
Posts: 20
Nutzer
Zitat:
Original von Primax:
@Maijestro:

Also, die Devices (ahi.device, keyboard.device, netinfo.device etc.) liegen bei mir unter "Mein MorphOS" --> "MOSSYS" --> "Devs".


Perfekt es hat geklappt…danke.

[ - Antworten - Zitieren - Direktlink - ]

07.09.2022, 19:47 Uhr

Primax
Posts: 324
Nutzer
@Maijestro:
Meine Mail bekommen...?

[ - Antworten - Zitieren - Direktlink - ]

08.09.2022, 03:51 Uhr

Maijestro
Posts: 20
Nutzer
@Primax:

Ich melde mich heute bei dir 😉

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > Qemu AmigaOs4.1/Morphos [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.