amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Amiga 2000 Model B 1986 Revision 4.5. 8486 [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

18.01.2019, 23:43 Uhr

amiga_2000
Posts: 10
Nutzer
Guten Tag

gemäss ehemaligen :commo: :boing: Mitarbeiter Rainer Benda soll ich mich hier im Forum melden.

Bei meinem Amiga 2000 ist die RTC Batterie (https://www.ebay.co.uk/itm/VARTA-3-6V-BATTERY-PCB-Mount-3-60DK-PC-3-V70-PC-3-V60R-PC-3-51FT-A-3-V70-3-V60R-/280801144022) ausgelaufen.

Der Amiga startet daher nicht mehr und zeigt mir nur einen gelben und grünen Bildschirm an. :(

Siehe hier: https://picload.org/view/dcilirgp/amiga2000.jpg.html und hier: https://picload.org/view/dcilirra/bildschirm.jpg.html

Aus diesen Übersicht über die Startfarben:
https://muggothek.de/retro-computing/amiga/hardware/amiga-startdiagnose/
http://www.l8r.net/technical/t-startupcolours.shtml

werde ich aber nicht ganz schlau:

Zudem blinkt die Power-LED 5x und macht dann einen Reset (GURU?).

So sah die Batterie beim öffnen aus:
https://picload.org/view/dcilirga/batterie1.jpg.html
und so nach der Reinigung:
https://picload.org/view/dcilirgl/batterie2.jpg.html

Brachte aber nichts und habe sie daher komplett entfernen und die entstandenen Löcher verlötet lassen.

Brachte weiter keine Änderung. Was könnte noch durch den Stillstand beschädigt worden sein?

Vielen Dank für hilfreiche Tipps.

Dani

[ - Antworten - Zitieren - Direktlink - ]

19.01.2019, 01:38 Uhr

Pharao
Posts: 42
Nutzer
@amiga_2000:
Die Batteriesäure hat die leiterzüge zerfressen mit nur reinigen ist es nich getan. Die säure muss neutralisiert werden.
Überprüfe die Leiterbahnen zwischen Batterie und rp900 brücke zudem wenn er lange stand miss die Netzteil Spannungen.

[ - Antworten - Zitieren - Direktlink - ]

23.01.2019, 01:39 Uhr

Camiga
Posts: 172
Nutzer
@amiga_2000:
Schwer zu sagen, was dein Amiga hat. Grüner Schirm bedeutet eigentlich, dass er "läuft", also zumindest den Selbsttest macht, d.h. Code im Kickstart ausführt. D.h. es kommt ein weißes Bild und die LED wird heller, findet dann aber einen Fehler und bricht den Boot-Prozess ab.

Meist ist es ein schwarzer Schirm, wenn bei der CPU oder dem Kickstart (Akkubereich) oder den Leiterbahnen was kaputt wird.

Dein Akku und die Platine sehen eigentlich noch sehr gut aus. Zuerst werden jedoch Metallteile angegriffen, d.h. die CPU solltest du rausnehmen, kontrollieren und zusammen mit dem Sockel reinigen und ggf. (wenn es grün ist) messen, ob alles noch OK ist. Sollte der Sockel selbst sehr "grün" sein auf den Akku-nahen Pins dann sollte man ihn tauschen - eine Reinigung hilft dann nciht mehr. Obwohl es etwas grün aussieht gehe ich nicht von einem großen Schaden aus - aber es sollte auf jeden Fall kontrolliert und gereinigt werde.

Grüner Schrim kann alles bedeuten, ich glaube da gibt es nicht so wirklich eine klare Aussage. Einige meinen es können Kontaktprobleme im Agnus Sockel sein, das ist der quadratische PLCC Chip.

Laut Liste in deinem Link:

Kontaktproblem / Defekt: RAM Baustein(e)
Kontaktproblem / Defekt: CIA-A Baustein
Kontaktproblem / Defekt: Agnus Baustein
Kontaktproblem / Defekt: ggf. IC Sockel

Also auch mal die 2 CIA 8520 austauschen gegeneinander.

Das Netzteil hat mit dem grünen Bildschirm nichts zu tun - entweder es geht oder nicht. Wenn das Netzteil innen geschlossen ist (Metall ist durchgängig an der Oberseite) ist es ein neueres/besseres.

Wenn das Netzteil jedoch mit einem Lochblech verschlossen ist (man kann rein sehen durch runde Löcher) dann ist es in Deutschland erzeugt worden, älter und - wie bei deutschen Sachen von Commodore üblich - schlechterer Qualität. Die verwendeten ROE (goldenen) Elkos neigen zu Ausfällen, speziell im A2000 (hatte schon 4-5 defekte) und müssen daher ausgetauscht werden. Hat nichts mit deinem Fehler zu tun, aber sollte jedenfalls, auch vorsorglich, gemacht werden. Ich glaube Rev 4.5 ist jedoch schon ein späteres Modell und du wirst vermutlich schon das (bessere) China-Netzteil haben.


Also CPU Sockel und CPU Pins reinigen, Agnus Sockel prüfen, CIAs ggf. tauschen.

[ - Antworten - Zitieren - Direktlink - ]

23.01.2019, 14:54 Uhr

ylf
Posts: 4070
Nutzer
Nimmt mal die CPU raus und reinige die Beinchen, sowie den Sockel.
Im Idealfall sollte man den Sockel erneuern. Die Säure zieht durch die Kapilarwirkung in den Sockel rein, sodaß sowohl Sockelkontakte alsauch CPU Beinchen oxidiert sind. Man sieht auf deinen Bildern den Grünspan! Ggf. hat es auch die benachbarten R-Netzwerke erwischt. Sollte man auch erneuern.

[ - Antworten - Zitieren - Direktlink - ]

25.01.2019, 23:08 Uhr

amiga_2000
Posts: 10
Nutzer
@Camiga:
@ylf:

Vielen Dank für die Antworten. Da die Batterie der "Computerfreak" ausgelötet hat, weiss ich ich jetzt nicht wie ich die CPU herausnehmen und reinigen soll. Muss diese auch ausgelötet werden?

Der Bildschirm wird NIE weiss! Und Schwarz ist er nie. Er wechselt höchstens mal noch die Farbe auf von grün auf orange/ocker-farbig, und bleibt dann auf diesem Status.

Was hat die Power-LED für eine Aufgabe wenn diese mehrmals blinkt und dann der Amiga einen Reset macht? Er zeigt immer die gleichen Farbmuster an.

Dieses Vorgehen ist aber nur noch mit Kick 1.3 zu sehen.
Beim Umschalten auf Kick 2.0 bleibt der Bildschirm schwarz!

Die LW machen keine "Klick-Geräusche"!

Im YT Video https://www.youtube.com/watch?v=_s-rrsABTKg habe ich gesehen, dass der Joystick in Port 2 eine Rolle spielen könnte.
Auch hier ist der Bildschirm grün beim Start.

Wo bekomme ich allenfalls noch die zu austauschenden Teile?
Das Netzteilgitter hat obwohl Rev. 4.5 noch Löcher. Ich weiss das, weil ich das Netzteil vom Gehäuse lösen musste (beim Computerfreak) und es dann vom Staub befreit habe.

Um die Batterie auslöten zu können musste ja das ganze Board aus dem Amiga-Gehäuse ausgebaut werden.

Vielen Dank für weitere Tipps.

[ - Antworten - Zitieren - Direktlink - ]

26.01.2019, 09:21 Uhr

ylf
Posts: 4070
Nutzer
Zitat:
Original von amiga_2000:
Vielen Dank für die Antworten. Da die Batterie der "Computerfreak" ausgelötet hat, weiss ich ich jetzt nicht wie ich die CPU herausnehmen und reinigen soll. Muss diese auch ausgelötet werden?
...
Wo bekomme ich allenfalls noch die zu austauschenden Teile?
...
Um die Batterie auslöten zu können musste ja das ganze Board aus dem Amiga-Gehäuse ausgebaut werden.
...

Die CPU ist nur in den Sockel gesteckt. Muss man vorsichtig heraushebeln. (Abwechselnd beidseitig)
Die Beinchen der CPU mit Wattestäbchen und Alkohol reinigen und anschließend die Oxidationen mittels Glasfaserstift entfernen.

Sockel reinigen unmöglich, ggf. mit Alkohol und alter Zahnbürste so'n bisschen.

Das Ausmaß des Befalls wird man vermutlich erst bei entnommender CPU richtig sehen. Die Sockel, die Commodore damals verbaut hat, waren auch richtig schlecht, nur einseitige Kontaktierung.
Wenn die CPU nicht getauscht werden soll bzw. an dieser Stelle keine Turbokarte hinein soll, empfiehlt es sich natürlich Sockel mit sog. Präzisionskontakten zu verwenden. Zum Auslöten/Austauschen des Sockels muss das Board natürlich wieder ausgebaut werden. Entsprechendes Ersatzmaterial (IC-Sockel) gibt es bei gut sortierten Elektronik-Händlern.

An deiner Stelle würde ich das erst mal mit dem Reinigen im Bereich der CPU versuchen, das bekommst du auch als Laie mit Hausmitteln hin.
Kickstartumschaltung würde ich für Funktionstests auch weglassen, Kickstart direkt reinstecken. Und bitte hochauflösende Bilder dabei machen. Das kann uns helfen den möglichen Schaden genauer zu beurteilen.

[ - Antworten - Zitieren - Direktlink - ]

26.01.2019, 22:53 Uhr

amiga_2000
Posts: 10
Nutzer
@ylf:

Vielen Dank mal fürs erste. Der Amiga steht immer moch beim Computerfreak.

Ich werde schauen, dass ich ihn zurückbekommen kann.

Leider wurden meine bisherigen Fotos alle schon gelöscht!

[ - Antworten - Zitieren - Direktlink - ]

27.01.2019, 13:31 Uhr

ylf
Posts: 4070
Nutzer
@amiga_2000:
achso, du hast den Rechner gar nicht bei dir ...
Du kannst den Sockel auch gleich tauschen (lassen).

[ - Antworten - Zitieren - Direktlink - ]

30.01.2019, 22:10 Uhr

amiga_2000
Posts: 10
Nutzer
@ylf:

Hallo

leider ist der "Computerfreak" doch nicht mehr so freaky, wie er mir vermittelt wurde.
Folgendes hat er mir geantwortet, als ich ihm deine Vorschläge geschrieben hatte:

Sorry, habe wirklich keine Zeit mehr für etwas, das nicht mehr reparierbar ist. Ich verstehe Dein Versuch, diesen genialen Computer zu reparieren, aber Du musst Dich damit abfinden, dass der A2000 definitiv Defekt ist.

Ist der A2000 definitiv Defekt? ?(

Sonst werde ich dann, wenn ich mal Zeit habe, den A2000 bei ihm abholen und es selber versuchen. Ist das schwer die CPU auszuhebeln?

Denn kaputt machen, kann ich dochts mehr?

Vielen Dank

[ - Antworten - Zitieren - Direktlink - ]

31.01.2019, 04:27 Uhr

Pharao
Posts: 42
Nutzer
@amiga_2000:

Schick ihn mir und ich reparier ihn

[ - Antworten - Zitieren - Direktlink - ]

31.01.2019, 15:24 Uhr

mir_egal
Posts: 532
Nutzer
nicht reparierbar ist der bestimmt nicht, hab schon viel schlimmere gesehen.

--
A1SE

Ängstlich zu sinnen und zu denken, wie man es hätte tun können, ist das übelste, was man tun kann.

[ - Antworten - Zitieren - Direktlink - ]

31.01.2019, 18:06 Uhr

ylf
Posts: 4070
Nutzer
Es ist schon viele Jahre her, da habe ich auch so einen Fall von Akkudefekt hier in der Region betreut. Das sah teilweise noch schlimmer aus, denn der Lötstoplack löste sich schon. Was auf den ersten Blick damals aber auch nicht gleich zu erkennen war, die von mir bereits erwähnten Oxidationen im CPU-Sockel. Aus dieser Erfahrung heraus weiß ich schon, wonach ich gucken muss. Auch wenn es auf deinen Bildern nur Indizien sind, sehr matte CPU-Beinchen, ein paar grüne Pixel, die oben am CPU Sockel bei Pin 1 hervorblitzen, so gehe ich doch jede Wette ein, das bei dir der Sockel ebenfalls einen von der Säure mitbekommen hat. Wenn man die CPU heraus nimmt, sieht man vermutlich, wie der Grünspan dort blüht wie auf einem Kupferdach einer alten Kirche! Das kann nicht funktionieren! Das war beim erwähnten Fall auch so, der Amiga startete zwar noch, aber nicht immer, er lief auch noch wenn er denn mal gestartet war, stürzte aber öfter ab. Wenn die Kontakte nicht 100% in Ordnung sind, kann mal hier, mal da, mal jetzt, mal später ein Bit verloren gehen. Das führt natürlich zu diffusen Fehlern.

Auch für den Fall, dass es diesmal nicht der Fehler ist, so ist es doch eine tickende Zeitbombe und beirrt die weitere Fehlersuche.

Zu deiner Frage, die CPU herauszuhebeln ist nicht schwer. Profis nehmen dazu ganz ungeniert einen kleinen Schraubendreher. Profis wissen aber auch aus Erfahrung heraus, wie viel Kraft sie aufbringen dürfen, bis was bricht. ;)
Ich würde dir ein oder zwei Eisstiele empfehlen. Die sind in der Regel aus Holz und damit ESD-technisch unbedenklich. Man kann die schön flach anschleifen, sodass sie einen breiten, flachen Keil bilden. Damit an den Stirnseiten zwischen Sockel und CPU fahren und vorsichtig hebeln bzw. den Keil vorschieben.

Vielleicht magst du uns auch grob deine Region nennen, wo du zuhause bist. Ggf. gibt es jamand in deinem Umkreis, der dir helfen kann.

[ - Antworten - Zitieren - Direktlink - ]

31.01.2019, 23:55 Uhr

amiga_2000
Posts: 10
Nutzer
@ylf:

Vielen Dank ylf.
Wie schon geschrieben, scheut der Computerfreak womöglich den Aufwand die CPU auszuhebeln. Oder er getraut sich nicht. So wie ich.

Leider wohne ich in der Schweiz. Dass reduziert die Möglichkeit, den Amiga zu euch zu bringen.

Ich versuche deshalb meinen Amiga so schnell wie möglich wieder zu bekommen.

[ - Antworten - Zitieren - Direktlink - ]

31.01.2019, 23:56 Uhr

amiga_2000
Posts: 10
Nutzer
@Pharao:

Der Amiga ist über 20 kg schwer!!

[ - Antworten - Zitieren - Direktlink - ]

01.02.2019, 11:34 Uhr

Pharao
Posts: 42
Nutzer
@amiga_2000:
Nicht den ganzen rechner nur mainboard
Und evtl netzteil wenn die spannungen nicht mehr stimmen.

[ - Antworten - Zitieren - Direktlink - ]

01.02.2019, 13:26 Uhr

Bjoern
Posts: 1670
Nutzer
Zitat:
Original von amiga_2000:
Wie schon geschrieben, scheut der Computerfreak womöglich den Aufwand die CPU auszuhebeln. Oder er getraut sich nicht. So wie ich.


...was allerdings nur eine Minute dauert und mit ylf's Anleitung ganz leicht zu bewerkstelligen ist. Ich würde einen Versuch wagen.

Grüße,
Björn

[ - Antworten - Zitieren - Direktlink - ]

01.08.2019, 13:02 Uhr

amiga_2000
Posts: 10
Nutzer
@Bjoern:
@Camiga:

Hallo

durch das Board hier, habe ich einen anderen Amiga User gefunden, welcher mein Amiga 2000 ausgebaut hat.

Soweit ich von ihm weiss, soll das Board und das Netzteil defekt sein (er hat es aber nicht geöffnet, soviel ich weiss, ist es aber ein deutsches Modell da es ein Lochgitter hat; Camiga hat davon was geschrieben).

Es kam ja immer der grüne Bildschirm. Aber nie schwarz!
https://abload.de/image.php?img=bildschirm6ikoe.jpg

Er hat zudem die CPU ausgehebelt und mir dann Fotos geschickt:
https://abload.de/image.php?img=board1owjhz.png
https://abload.de/image.php?img=board2cujqy.png

Jetzt kann er aber nicht beziffern, was noch alles kaputt sein könnte, Der Agnus funktioniere aber. (Da er selber noch einen A2000 hat).

Er hat mir einen Link zu einem A2000-Board geschickt, welches bei Ebay verkauft wird:

https://www.ebay.de/itm/Gibt-es-nicht-Sehr-seltenes-Mainboard-Amiga-2000-Rev-4-Kick-1-2-Agnus-8371/223492229299

Würde es Sinn machen, dieses Board zu kaufen, und dann meine ganzen Erweiterung damit zu nutzen, obwohl ich ein Rev. 4.5 Board mit Kick 1.3 und 2.04 Umschalter benutze mit Agnus 8486 plus 6x1 MB RAM, GVP SCSI Karte mit Quantium HDD und Multivision FlickerFlixer Karte für den Anschluss eine Eizo VGA Monitor?

Hier ein ähnliches Foto des betroffende Board: https://abload.de/image.php?img=a2000rev45-editmkj0v.jpg (Ist aber NICHT mein Board, hierzu habe ich KEIN Foto, das benutzte Foto habe ich früher einmal gefunden, sollte aber meins wiederspiegeln. Brauchte ich betreffend des Batterie-Problems.)

VOR dem Entfernen der ausgelaufenen Batterie
https://abload.de/image.php?img=batterie2elk6e.jpg
https://abload.de/image.php?img=batterie138jfh.jpg
und dem Prozessor. Und der Reinigung. Leider habe ich keine aktuelleren Fotos.

Vielen Dank

PS. Müsste das Netzteil, repariert oder ersetzt werden? Auf was müsste geachtet werden?

PS. Gibt es einen Unterschied zwischen den verschieden Revisionen des A2000 Board 4, 4.5 und 6.2? Habe gelesen, dass Rev. 6.2 mit Kick 3.1 ausgeliefert worden ist. Funktioniert hier das Board noch mit einem Kick 1.2/1.3 und OCS für die alten A500 Spiele, welche vor der Zeit von Kick/WB 2.04/3.1 erschienen sind?

Denn ich habe auch schon ein A2000 Board Rev. 6.2 zum Verkauf gesehen.
ZB.: https://www.ebay.de/itm/Sehr-schones-Amiga-2000-Mainboard-Rev-6-Kick-1-3-Agnus-8372-kein-Akkuschaden/223607836517

Vielen Dank nochmals.



[ Dieser Beitrag wurde von amiga_2000 am 03.08.2019 um 00:34 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

01.08.2019, 17:20 Uhr

Pharao
Posts: 42
Nutzer
@amiga_2000:wenn du das board mir sendest reparier
Ichs. nicht reparieren gibts fast nicht, hatt ich nur mit gebrochen board u blitzschaden.
Ausgelaufene batterie ist kein nicht reparabel.

Kopfschmerzen bereiteten mir immer kaschierter pfusch aber jetzt kenn ich die spielchen.

[ - Antworten - Zitieren - Direktlink - ]

02.08.2019, 23:39 Uhr

amiga_2000
Posts: 10
Nutzer
@Pharao:
Hallo

vielen Dank für deine Antwort.
Wo wohnst du denn?
Und wieviel verlangst du für die Reparatur? Es ist ja nicht sicher, ob es wirklich am Board alleine liegt.

[ - Antworten - Zitieren - Direktlink - ]

03.08.2019, 11:00 Uhr

ylf
Posts: 4070
Nutzer
Also wie vielleicht schon gesagt, ich hatte vor Jahren auch schon mal so einen ähnlichen Fall.
Ich würde auf jeden Fall den CPU Sockel erneuern, die damaligen originalen taugen nichts, das Umfeld reinigen und dann sieht man mal weiter. Weil so ein Sockel kostet nur ein paar Euro (Cent), das größere Problem ist der Arbeitsaufwand, den man da rein stecken muss. Aber Amiga-User mit Lötkenntnissen machen sowas gerne. Und die Chancen stehen gut, dass damit das Problem behoben ist. Die CPU ist das zentrale Teil, wenn die keinen zuverlässigen Kontakt hat, kann das zu allem möglichen Fehlverhalten führen.
Die damalige Technik ist noch überschaubar, wie Pharao schon sagte, das bekommt man hin!

[ - Antworten - Zitieren - Direktlink - ]

04.08.2019, 11:13 Uhr

amiga_2000
Posts: 10
Nutzer
@ylf:

Danke. Würde es erstmals reichen die CPU welche hier angeboten wird:

https://www.ebay.de/itm/Motorola-CPU-68000-fur-Atari-AMIGA-500-A2000-CDTV-0022018/283512502736

auszutauschen?

[ - Antworten - Zitieren - Direktlink - ]

04.08.2019, 12:25 Uhr

ylf
Posts: 4070
Nutzer
@amiga_2000:
Nein, ich glaube, wir haben uns da falsch verstanden. Der CPU-Sockel muss getauscht/erneuert werden, z.B. sowas hier.
Eine neue CPU hilft dir nicht weiter, da die alte vermutlich noch funktioniert.

[ - Antworten - Zitieren - Direktlink - ]

04.08.2019, 22:45 Uhr

amiga_2000
Posts: 10
Nutzer
@ylf:
Vielen Dank.
Der Sockel, welche die CPU hält, muss also aus dem Board ausgelötet werden? So wie die aufgelaufene Batterie?
Das wird vermutlich ein grosser Zeitaufwand werden?

Ich habe ja ein Foto des ausgebauten Prozessor in einer früheren Antwort eingestellt und dieser sieht ja schon sehr mitgenommen aus.

[ - Antworten - Zitieren - Direktlink - ]

05.08.2019, 20:02 Uhr

mir_egal
Posts: 532
Nutzer
der Sockel ist für einen geübten Löter schnell getauscht. mehr Zeit frisst das gründliche Reinigen.

schau auch mal im Bereich der Tastaturbuchse genauer hin, hier muss man meistens auch ran, die Batteriesäure kriecht im laufe der Jahre langsam weiter, vor allem unter den Bauteilen. wenn man hier nur flickt und das nicht komplett überholt hat man das gleiche Problem nach paar Jahren wieder.


--
A1SE

Ängstlich zu sinnen und zu denken, wie man es hätte tun können, ist das übelste, was man tun kann.

[ - Antworten - Zitieren - Direktlink - ]

19.08.2019, 14:53 Uhr

mindcook
Posts: 3
Nutzer
Hallo, war in den Ferien Jungs....

Dieser A2000 von Dani steht aktuell bei mir. Hab ihn komplett auseinandergenommen.

Es wurde hier im Tread einiges durcheinandergebracht.

-> Board Rev. 4.5, läuft nicht
-> NT scheint auch nicht mehr zu wollen (muss noch genauer getestet werden)
-> Multivision 2000 läuft bei mir auch nicht (muss noch genauer getestet werden)
-> Akku ist raus
-> CPU und Amiga Chips wurden getestet, alle OK und ich hab sie gerade auch gewaschen.
-> Board hat Akku und sonstigen Siff verteilt-> mal gewaschen
-> Es sind auch andere Schäden sichtbar (Schraubenzieher in Slot gewürgt?!?)...Lötresten auf dem Board.....
-> .....

Bei Bedarf habe ich auch Fotos. Der Schaden sollte aber mit Ersetzten der versifften/defekten Teile grösstenteils reparierbar sein. Weitere Schäden nicht auszuschliessen.

Da ich momentan keine Ersatzteile habe und selber noch A2000 mit Akkuschaden habe, bin ich um jede Hilfe dankbar.

-> Pharao, mir_egal, weitere Leute...woher seid ihr?

LG aus der Schweiz
mc

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Amiga 2000 Model B 1986 Revision 4.5. 8486 [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.